Compiz Experimental Plugins U/D 3-18-12
Compiz Themes
Description:

Note these are experimental I have used them for some time with no issues.
32 and 64 bit !
For compiz 8.x will work in compiz 9.x! UPDATE !

>> FIND YOUR COMPIZ VERSION
compiz --version

Changelog:

5 years ago

Credit goes to original author!
Scott Moreau oreaus@gmail.com
Thanks!
1.1 Corrected misplaced command.

1.2 ADDED Compiz dependencies!

2.0 Completely new script! I just tried it on my 32bit Lucid and had no issues!!If any errors come up while installing run ./compiz-addons install all nohup compiz --replace & again!
Try it and let me know! Sorry for any inconvenience!
Spread out commands,
Added credits and comment

2.1 Added script and how to to download link.And I hope it works for all!

2.2 Added Atlantis and 3D-Cube Model

3.5 for 11.++ And 12.++
new D/L for you

4.0 Cleaned up scripts and added support for compiz 8x & 9x in separate scripts !

4.5 Added Galaxy live wallpaper !
by ilap ! Thanks!! for maverick,natty, oneiric and precise!

Add this ppa to your source list, and take a tripp in to the Galaxy !!

2-4-12 added how to compile Galaxy live wallpaper for lucid.
Thanks for the heads up modal1 !

Update 3-17-12 5.0
uncommented jcanimations,wizard,gost simple animations and experimental animations, NOW, All plugins should work in compiz 9.4, BUT some will not be installed in compiz 9.7 Presice ! as the animation dependancy has not been updated in 9.7 ! They have A LOT of work to do to compiz to make it work right ! AGAIN These plugins are EXPERIMENTAL ! They work best in Gnome fallback, but do work in unity,Oneiric compiz 9.4 both with and with out the cube, at this point 9.7 has no cube ! and Many bugs, Be carefull !

Update 3-18-12
>> HOW TO UNINSTALL THESE PLUGINS
./compiz-addons uninstall all

If you installed Gallaxy, and want to remove it, Open synaptic, and search galaxy live wallpaper, mark for complete removal

5 years ago

drpaulaner

thx, you have to start the install script again with uninstall all as option

Report

5 years ago

drpaulaner

how can I purge it to get a clean system?

Report

5 years ago

johnnyg

Thank for the post, I have been meaning to add this !
./compiz-addons uninstall all

Report

5 years ago

modal1

Just a heads up, Galaxy Live Wallpaper doesn't work with Lucid. "Failed to fetch http://ppa.launchpad.net/ilap/lwp/ubuntu/dists/lucid/main/binary-i386/Packages.gz 404 Not Found"

Report

5 years ago

johnnyg

Thanks for the Heads up ! I will up date with a how to compile Galaxy live wallpaper for lucid !
Thanks again !

Report

5 years ago

CraigFoote

craig@notebook:~/Downloads/compiz-exp-plugins$ compiz --version
Compiz 0.9.6
craig@notebook:~/Downloads/compiz-exp-plugins$ sh compiz-addons-09
compiz-addons-09: 54: [[: not found
compiz-addons-09: 61: [[: not found
compiz-addons-09: 68: [[: not found
compiz-addons-09: 70: Syntax error: "(" unexpected

craig@notebook:~/Downloads/compiz-exp-plugins$

Report

5 years ago

CraigFoote

D'oh! I doubleclicked and ran in terminal, as instructions stated, and things appear to be working. Sorry for the noise.

Noob

Report

5 years ago

modal1

Has anyone else experienced a loss of window decorations when using the experimental plugins and Emerald? Oddly I lose all open roxterm windows, but not other programs. Reloading the window manager brings them back but this happens often enough that it became unusable. Any suggestions?

Report

5 years ago

ferdynator

try [CTRL]+[ALT]+[F1], then type "sudo service gdm stop" and "sudo service gdm start". Worked for me :)

Report

5 years ago

modal1

Thanks, I will try that

Report

5 years ago

modal1

I ended up doing a fresh install and installed the updated plugins and the issue did not arise again.

Report

5 years ago

modal1

I ended up doing a fresh install and installed the updated plugins and the issue did not arise again.

Report

5 years ago

kuznec82

hey man great work ..have you some sounds for window actions?

Report

5 years ago

johnnyg

In sounds plugin, navigate to usr/share/sounds/ubuntu/stereo, and add what you like, or see
http://gnome-look.org/index.php?xcontentmode=25 for more great system sounds ! here are some I have done ! enjoy !
http://gnome-look.org/content/show.php/new_remix-5-sounds?content=108674

Report

5 years ago

milboy

File not found and it's been since yesterday

Report

5 years ago

johnnyg

This is what you would get in the D/L ! . . . .


sudo apt-get install git

cd ~/Downloads

sudo apt-get install compiz-fusion-bcop compiz-dev \build-essential libtool \libglu1-mesa-dev libxss-dev \libcairo2-dev git-core
git clone git://anongit.compiz.org/users/soreau/scripts

cd scripts

./compiz-addons install all

nohup compiz --replace

NOTE : One command at a time ! ;)
Copy and past to your text editor and save as you wish,!
You may have to reboot !! =) Hope this helps !

Report

5 years ago

milboy

OK. thx

Report

5 years ago

rdsheets

Running 10.04 LTS 32 bit with Compiz 0.8.4. First tried the manual method using the instructions in the post. Did nothing but create a scripts folder in my download folder. Then I downloaded the scripts and how-to from the Gnome-look page and tried it that way. Same result. NOTHING. This is what I get in terminal:

"robert@robert-desktop:~$ sudo apt-get install compiz-fusion-bcop compiz-dev \build-essential libtool \libglu1-mesa-dev libxss-dev \libcairo2-dev git-core
[sudo] password for robert:
Reading package lists... Done
Building dependency tree
Reading state information... Done
compiz-fusion-bcop is already the newest version.
compiz-dev is already the newest version.
build-essential is already the newest version.
libtool is already the newest version.
libglu1-mesa-dev is already the newest version.
libxss-dev is already the newest version.
libcairo2-dev is already the newest version.
git-core is already the newest version.
The following packages were automatically installed and are no longer required:
python-renderpm libgfortran3 xdotool python-lxml python-reportlab-accel
python-numpy libwmf-bin libmagick++2 python-uniconvertor libblas3gf
liblapack3gf python-vobject perlmagick python-reportlab
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 3 not upgraded.
robert@robert-desktop:~$ cd Downloads/scripts
robert@robert-desktop:~/Downloads/scripts$ ./compiz-addons install all
Installing all plugins without prompting.
Installing dependencies..
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package git is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
E: Package git has no installation candidate
Initialized empty Git repository in /home/robert/src/compiz/plugins/anaglyph/.git/
remote: Counting objects: 131, done.
remote: Compressing objects: 100% (127/127), done.
remote: Total 131 (delta 62), reused 0 (delta 0)
Receiving objects: 100% (131/131), 30.02 KiB, done.
Resolving deltas: 100% (62/62), done.
Building anaglyph..
./compiz-addons: line 125: cmake: command not found
make: *** No targets specified and no makefile found. Stop."
After this I get the same thing over and over for each plugin. Finally ending with:
"make: *** No rule to make target `install'. Stop.
Done.
Don't forget to restart compiz and ccsm after installing or removing any plugin. Enjoy! :-)
robert@robert-desktop:~/Downloads/scripts$ "

Anyone have any ideas? Am I just not seeing something really obvious? I'm still fairly new to Ubuntu and Linux in general. Any help is appreciated and thanks in advance.


Report

5 years ago

w1d3

the answer is quite simple insted of using the command ./compiz-addons install all try ./compiz-addons-0.8 install all ;) it took me a while to figure this out .. xD

Report

5 years ago

milboy

work fine on 10.04 LTS. Thank you

Report

6 years ago

echo0

thanks man !! works very well with * ubuntu 10.10 64 bit*

Report

6 years ago

johnnyg

Errors should be resolved ! the repository was down for a bit, ignore error messages while these plugins are being installed, they are do to the missing Hicolor Icons that are not in the repo at this time !

Report

6 years ago

jasbutut

Installed, and no error. Thanks!

Report

6 years ago

sakasa

Great work you are doing, looking good my friend.

Besy regards,

Report

6 years ago

iruel

make it ppa please

Report

Supporters

Recent Donations

Be the first to donate
Filename Version Description Filetype Packagetype License Downloads Date Filesize Install
Score 74%
74.00 Likes
26 Dislikes

0 Supporters for Compiz Experimental Plugins U/D 3-18-12:

Recent Donations:

Be the first to donate
show all
Details
version
5.0 UPDATE!
updated Mar 18 2012
added Jan 13 2010
downloads
page views 4161
support johnnyg
For The Product
Compiz Experimental Plugins U/D 3-18-12
5 - 10 - 25 - 50 - 100 - 200 - 500